Back to overview
Resolved

Calls not being picked up by our AI agent

Jun 18, 2026 at 10:00pm UTC
Affected services
API

Resolved
Jun 18, 2026 at 11:57pm UTC

Our vendor has rolled back a configuration change and we are noticing calls reaching our agent in a healthy manner. Apologies for the disruption

Created
Jun 18, 2026 at 10:00pm UTC

We have observed calls not being picked up by our systems, caused by a provider configuration change. We have escalated it as P0 and are working with them to restore service