Degraded call performance
Resolved
May 21, 2026 at 6:46pm UTC
Normal call service has been restored, and the issue has been resolved. We will continue monitoring to ensure the service remains stable.
Affected services
Updated
May 21, 2026 at 6:32pm UTC
We have restored normal call routing and are closely monitoring performance to ensure the service remains stable.
Affected services
Updated
May 21, 2026 at 5:56pm UTC
Affected inbound calls continue to be redirected to fallback numbers while we work to restore normal call routing. We will provide another update as soon as more information is available.
Affected services
Updated
May 21, 2026 at 4:36pm UTC
We are now redirecting calls directly to fallback numbers while our team continues working to resolve the issue, which stems from a third party vendor. We’ll share additional updates as more information becomes available.
Affected services
Created
May 21, 2026 at 3:00pm UTC
We’re currently experiencing degraded call performance, with the AI not responding as expected. Our team is actively investigating and working to resolve the issue. We’ll share updates as more information becomes available.
Affected services