Back to overview
Resolved

Degraded call performance

May 12, 2026 at 4:10pm UTC
Affected services
API

Resolved
May 12, 2026 at 5:01pm UTC

Provider has rolled back a bad deployment and we are seeing metrics return to healthy. We will keep monitoring

Created
May 12, 2026 at 4:10pm UTC

We've noticed a subset of calls failing to initialize due to a provider failure and are currently investigating